Se publica la versión estable de Propel 1.6

Propel es el ORM favorito de una gran parte de la comunidad de programadores Symfony. Hace unos años era el mejor ORM y el más utilizado. Tras un largo período de inactividad, Doctrine se convirtió en el ORM más popular y ahora Propel intenta recuperar lo perdido.

Para ello se acaba de publicar la versión estable de Propel 1.6, la última que se publicará de la rama 1.X. A pesar de que la lista de novedades de Propel 1.6 es casi inacabable, esta nueva versión es completamente retrocompatible con las versiones 1.4 y 1.5.

Las principales novedades de Propel 1.6 son las siguientes:

  • Migraciones. Si añades o eliminas tablas y columnas en tu base de datos, Propel se encargará de hacer los cambios necesarios para que la aplicación siga funcionando bien y sin perder información.
  • Nuevos comportamientos. Doctrine2 ha eliminado todos los comportamientos, pero Propel cada vez tiene más. Los últimos son Versionable (que permite guardar una versión para cada cambio en un objeto) y i18n (para hacer aplicaciones multi-idioma sin depender de lo que ofrezca cada framework).
  • Importación y exportación de información en los formatos XML, YAML, JSON y CSV.
  • Tipos de columna avanzados. Se han añadido los tipos enum, array y object.

Puedes ver otras novedades destacadas en el post del blog oficial de Propel y en la extensa documentación oficial de Propel 1.6.

Si programas aplicaciones con symfony 1.4, ya puedes utilizar Propel 1.6 mediante el plugin sfPropel15Plugin (que no te confunda el nombre, porque este el plugin bueno para utilizar Propel 1.6). Si programas con Symfony2, debes utilizar el bundle PropelBundle.

Por otra parte, el desarrollo de Propel 2 ya ha comenzado y puedes seguir su evolución mediante su repositorio oficial en github: https://github.com/fzaninotto/Propel2

Fuente: Propel 1.6 is Released

Comentarios

  1. Yo soy uno de esos a los que les mola más Propel. Echaré un ojo a Propel2.

    Asier el 13 de mayo de 2011 22:53:43

  2. Ayer actualicé Propel en varias aplicaciones con el plugin sfPropel15Plugin. Entonces significa que la versión 1.6 está contenida actualmente en el mismo??? Lo pregunto porque o bien estoy leyendo mal, o en el changelog del plugin no he leido nada acerca del tema... 1 saludo y gracias!

    Ignacio G. el 14 de mayo de 2011 12:34:36

  3. Significa eso Ignacio Propel 1.6 esta contenido en el plugin sfPropel15Plugin lo puedes confirmar en el blog de propel en el post del release http://propel.posterous.com/propel-16-is-released en la sección Symfony Integration.

    Piero Recchia el 19 de mayo de 2011 03:34:24

  4. Muchas gracias Piero.

    Ignacio G. el 19 de mayo de 2011 16:09:50

Este artículo ya no permite añadir más comentarios.
¿Por qué? Los artículos cierran sus comentarios automáticamente unos meses después de su publicación para asegurar que estos sigan siendo relevantes.

Compartir en

Publicada el

13 de mayo de 2011

Etiquetas

Proyectos Symfony destacados

La forma más sencilla de generar el backend de tus aplicaciones Symfony. Ver más

Descargas totales de Symfony

1.069.955.393

Ver descargas en tiempo real

Síguenos en @symfony_es para acceder a las últimas noticias.