Se publica la versión estable de Symfony 2.1.0

La esperadísima versión estable de Symfony 2.1.0 acaba de ser publicada. Apenas unas horas después del lanzamiento de Zend Framework 2 el proyecto Symfony responde con el lanzamiento más esperado del año.

Como su propio número de versión indica, Symfony 2.1 no es una revolución respecto a Symfony 2.0, sino una mejora en casi todos sus aspectos. Salvo en el caso de los formularios, los cambios introducidos no son drásticos, por lo que no resultará demasiado costoso actualizar las aplicaciones.

Algunas cifras que resumen el trabajo realizado desde la versión anterior: más de 3.500 commits, más de 1.100 pull requests recibidas de cientos de programadores de todo el mundo, más de 6.000 tests unitarios añadidos, y más de 3.000 líneas de documentación modificadas.

¿Quieres probar Symfony 2.1 cuanto antes? Si dispones de PHP 5.4 y Composer, ejecuta el siguiente comando para descargar, instalar y ejecutar Symfony 2.1 en un servidor web de pruebas en el puerto 8888:

$ composer.phar create-project symfony/framework-standard-edition && cd framework-standard-edition && ./app/console server:run

Si estás pensando en actualizar tus aplicaciones, recuerda que tienes un documento llamado UPGRADE que explica con todo detalle qué ha cambiado desde Symfony 2.0.

Fuente: Symfony 2.1.0 released

Comentarios

  1. Con ganas de utilizar la nueva versión!

    Sergio Moya el 6 de septiembre de 2012 15:52:16

  2. Actualizando los proyectos :)

    Luis Fernando Vera Ortíz el 6 de septiembre de 2012 16:04:39

  3. pregunta: alguien sabe si sf2.1 anda en PHP 5.3??

    javier Martinez Echenique el 6 de septiembre de 2012 17:16:42

  4. Gracias Javier por la información. ¿Sabes aproximadamente cuándo tendrás tu libro de la versión 2.1?

    Gracias!!!

    Jorge Fabá Ferrández el 6 de septiembre de 2012 18:26:55

  5. Javier, Symfony 2.1 funciona tanto en PHP 5.3 como en PHP 5.4.

    Jorge, todavía no se cuándo estará lista la versión 2.1 del libro.

    Javier Eguiluz el 6 de septiembre de 2012 18:35:42

  6. Creo que Javier en el articulo con lo de "Si dispones de PHP 5.4 y Composer, ejecuta el siguiente comando..." se refiere a que para poder probarlo en un servidor con el comando ./app/console server:run, necesitas las versión PHP 5.4 ya que es la que incorpora un servidor propio.

    Pero Symfony 2.1 funciona en PHP 5.3, solo que como digo necesitas PHP 5.4 si quieres hacer lo del servidor que indican arriba.

    Saludos!

    Pablo Fernández Franco el 7 de septiembre de 2012 00:14:28

  7. Es realmente una buena noticia.

    alejandro brun el 7 de septiembre de 2012 18:22:04

  8. tengo toda la noche sufriendo =(, me descargue la version 2.1 para empezar con la nueva version a aprender symfony la version que tenia antes 2.0.13 me corrio perfecto, pero en cambio esta me presento este error

    SCREAM: Error suppression ignored for ( ! ) Warning: require(C:\wamp\www\Symfony\app/../vendor/autoload.php): failed to open stream: No such file or directory in C:\wamp\www\Symfony\app\autoload.php on line 5

    SCREAM: Error suppression ignored for ( ! ) Fatal error: require(): Failed opening required 'C:\wamp\www\Symfony\app/../vendor/autoload.php' (include_path='.;C:\php\pear') in C:\wamp\www\Symfony\app\autoload.php on line 5

    realizando el mismo procedimiento que hice con el otro dentro de la carpeta wamp www pego symfony y chequeo que todo este en orden

    instale por consola de windows el pear pero nada =( estoy desahuciada.

    Carla Ramirez el 9 de septiembre de 2012 12:58:37

  9. listo!!! era que me estaba descargando un archivo dañado de la pagina de symfony =S y le faltban unas cosas

    Carla Ramirez el 9 de septiembre de 2012 18:31:25

  10. Llevo varios días intentando actualizarme a Symfony 2.1. He seguido desde los inicios Symfony 2.0 y no tuve ningún tipo de problema, incluso he llegado a tener unos conocimientos bastante buenos sobre este framework. Pero ahora me encuentro totalmente perdido para actualizarme a Symfony2.1.

    Tengo un proyecto en Sf 2.0 y no tengo ni idea de como actualizarlo, he leído todo tipo de documentación, el upgrade de cambios.. todos los artículos de esta web y nada.

    ¿Que tengo que crear un proyecto de cero y luego ir incorporando mi proyecto existente? ¿Puedo actualizar el que ya tengo y luego hacer los cambios pertinentes?

    Tengo instalada la última version de composer., estoy en localhost coon PHP/5.3.6-13ubuntu3.7. Por favor alguien me podría orientar, no quiero haber llegado hasta aquí para ahora quedarme atrás.

    Un saludo y mil gracias! : )

    Pablo cccc el 14 de septiembre de 2012 13:26:00

  11. Yo apenas empeze el desarrollo un proyecto con Symfony2.0, y desde el principio lo he venido siguiendo, ahora con la 2.1 apenas voy a ver como actualizarlo, pero si cambia bastante la forma de actualizacion, almenos para mi qu enunca he usado composer.

    Jeronimo Salazar Ramírez el 14 de septiembre de 2012 20:07:03

Este artículo ya no permite añadir más comentarios.
¿Por qué? Los artículos cierran sus comentarios automáticamente unos meses después de su publicación para asegurar que estos sigan siendo relevantes.

Compartir en

Publicada el

6 de septiembre de 2012

Proyectos Symfony destacados

La plataforma de eCommerce 100% Symfony que rivaliza con Magento y PrestaShop. Ver más

Descargas totales de Symfony

1.069.955.393

Ver descargas en tiempo real

Síguenos en @symfony_es para acceder a las últimas noticias.